X.Org libXfixes CVE-2016-7945 Multiple Integer Overflow Vulnerabilities



X.Org libXfixes is prone to multiple integer-overflow vulnerabilities.

An attacker can exploit this vulnerability to execute arbitrary code. Failed exploit attempts will likely cause denial-of-service conditions.

libXfixes versions 1.7.6 and prior are vulnerable.

Information

Bugtraq ID: 93364
Class: Boundary Condition Error
CVE: CVE-2016-7945

Remote: Yes
Local: No
Published: Oct 04 2016 12:00AM
Updated: Apr 13 2017 12:03AM
Credit: Tobias Stoeckmann from the OpenBSD.
Vulnerable: X.org libXi 1.7.6
X.org libXi 1.7.2
X.org libXi 1.7.1
X.org libXi 1.6.2
X.org libXi 1.6.1
X.org libXi 1.6
Gentoo Linux


Not Vulnerable:


Related Posts

Comments