Adobe Flash - ATF Parser Heap Corruption

EDB-ID: 42249
Author: Google Security Research
Published: 2017-06-23
CVE: CVE-2017-3078
Type: Dos
Platform: Multiple
Aliases: N/A
Advisory/Source: Link
Tags: N/A
Vulnerable App: N/A

  
The attached file causes heap corruption in the ATF parser. To reproduce the issue, copy atffree.atf and LoadImage.swf to a server, and visit http://127.0.0.1/LoadImage.swf?img=atffree.png.


Proof of Concept:
https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/42249.zip

Related Posts

Comments