ownCloud CVE-2017-9338 Cross-Site Scripting Vulnerability



ownCloud is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

Information

Bugtraq ID: 99322
Class: Input Validation Error
CVE: CVE-2017-9338

Remote: Yes
Local: No
Published: Jun 28 2017 12:00AM
Updated: Jun 28 2017 12:00AM
Credit: Ahsan Khan
Vulnerable: ownCloud ownCloud 10.0.1
ownCloud ownCloud 10.0
ownCloud ownCloud 9.1.5
ownCloud ownCloud 9.1.1
ownCloud ownCloud 9.0.9
ownCloud ownCloud 9.0.5
ownCloud ownCloud 9.0.3
ownCloud ownCloud 9.0.2
ownCloud ownCloud 9.0.1
ownCloud ownCloud 8.2.11
ownCloud ownCloud 8.2.6
ownCloud ownCloud 8.2.2
ownCloud ownCloud 9.1.2
ownCloud ownCloud 9.0.6
ownCloud ownCloud 9.0.4
ownCloud ownCloud 8.2.9
ownCloud ownCloud 8.2.7


Not Vulnerable: ownCloud ownCloud 10.0.2
ownCloud ownCloud 9.1.6
ownCloud ownCloud 9.0.10
ownCloud ownCloud 8.2.12


Exploit


An attacker can exploit this issue by enticing an unsuspecting victim to follow a malicious URI.


Related Posts

Comments