Jenkins Multiple Plugins Multiple HTML Injection Vulnerabilities



Jenkins multiple plugins are prone to multiple HTML-injection vulnerabilities because it fails to properly sanitize user-supplied input.

Successful exploits will allow attacker-supplied HTML and script code to run in the context of the affected browser, potentially allowing the attacker to steal cookie-based authentication credentials or control how the site is rendered to the user. Other attacks are also possible.

The following products are affected:

DRY Plugin 2.48 and prior versions are vulnerable.
Static Analysis Utilities Plugin 1.91 and prior versions are vulnerable.

Information

Bugtraq ID: 101061
Class: Input Validation Error
CVE: CVE-2017-1000102
CVE-2017-1000103

Remote: Yes
Local: No
Published: Sep 29 2017 12:00AM
Updated: Sep 29 2017 12:00AM
Credit: Oleg Nenashev, CloudBees, Inc.
Vulnerable: Jenkins-Ci Static Analysis Utilities Plugin 1.91
Jenkins-Ci DRY Plugin 2.48


Not Vulnerable: Jenkins-Ci Static Analysis Utilities Plugin 1.92
Jenkins-Ci DRY Plugin 2.49


Exploit


An attacker can exploit this issue using a web browser.


References:

Related Posts

Comments