RubyGems CVE-2017-0901 Local Arbitrary File Overwrite Vulnerability



RubyGems is prone to a local arbitrary file-overwrite vulnerability because it fails to properly sanitize user-supplied data.

Attackers can overwrite arbitrary files on an unsuspecting user's computer in the context of the vulnerable application. Due to the nature of this issue, arbitrary code-execution may be possible.

RubyGems version 2.6.12 and prior versions are affected.

Information

Bugtraq ID: 100580
Class: Design Error
CVE: CVE-2017-0901

Remote: No
Local: Yes
Published: Sep 01 2017 12:00AM
Updated: Sep 01 2017 12:00AM
Credit: Yusuke Endoh.
Vulnerable: RubyGems RubyGems 2.4.8
RubyGems RubyGems 2.4.7
RubyGems RubyGems 2.4.6
RubyGems RubyGems 2.4.5
RubyGems RubyGems 2.4.4
RubyGems RubyGems 2.4.3
RubyGems RubyGems 2.4.2
RubyGems RubyGems 2.4.1
RubyGems RubyGems 2.4
RubyGems RubyGems 2.2.5
RubyGems RubyGems 2.2.4
RubyGems RubyGems 2.2.3
RubyGems RubyGems 2.2.2
RubyGems RubyGems 2.2.1
RubyGems RubyGems 2.2
RubyGems RubyGems 2.0.17
RubyGems RubyGems 2.0.16
RubyGems RubyGems 2.0.15
RubyGems RubyGems 2.0.14
RubyGems RubyGems 2.0.13
RubyGems RubyGems 2.0.12
RubyGems RubyGems 2.0.11
RubyGems RubyGems 2.0.10
RubyGems RubyGems 2.0.7
RubyGems RubyGems 2.0.6
RubyGems RubyGems 2.0.5
RubyGems RubyGems 2.0.4
RubyGems RubyGems 2.0.3
RubyGems RubyGems 2.0.2
RubyGems RubyGems 2.0.1
RubyGems RubyGems 2.0
RubyGems RubyGems 1.8.27
RubyGems RubyGems 1.8.24
RubyGems RubyGems 1.8.23
RubyGems RubyGems 1.8.21
RubyGems RubyGems 1.8.18
RubyGems RubyGems 1.8.16
RubyGems RubyGems 1.8.15
RubyGems RubyGems 1.8.14
RubyGems RubyGems 1.8.13
RubyGems RubyGems 1.8.11
RubyGems RubyGems 1.8.10
RubyGems RubyGems 0.9.1
RubyGems RubyGems 0.9
RubyGems RubyGems 0.8.11
RubyGems RubyGems 2.6.12
RubyGems RubyGems 2.1.4
RubyGems RubyGems 2.1.0
RubyGems RubyGems 2.0.9
RubyGems RubyGems 2.0.8
RubyGems RubyGems 1.9.3
RubyGems RubyGems 1.9.0
RubyGems RubyGems 1.8.8
RubyGems RubyGems 1.8.7
RubyGems RubyGems 1.8.6
RubyGems RubyGems 1.8.5
RubyGems RubyGems 1.8.4
RubyGems RubyGems 1.8.3
RubyGems RubyGems 1.8.28
RubyGems RubyGems 1.8.26
RubyGems RubyGems 1.8.25
RubyGems RubyGems 1.8.23.2
RubyGems RubyGems 1.8.23.1
RubyGems RubyGems 1.8.22
RubyGems RubyGems 1.8.20
RubyGems RubyGems 1.8.2
RubyGems RubyGems 1.8.19
RubyGems RubyGems 1.8.17
RubyGems RubyGems 1.8.12
RubyGems RubyGems 1.8.1
RubyGems RubyGems 1.8.0


Not Vulnerable: RubyGems RubyGems 2.6.13


Exploit


The researcher has created a proof-of-concept to demonstrate the issue. Please see the references for more information.


Related Posts

Comments