Apache Wicket CVE-2012-5636 Cross Site Scripting Vulnerability



Apache Wicket is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and launch other attacks.
Apache Wicket 1.4.x prior to 1.4.22, 1.5.x prior to 1.5.10, and 6.x prior to 6.4.0 are vulnerable.

Information

Bugtraq ID: 101644
Class: Input Validation Error
CVE: CVE-2012-5636

Remote: Yes
Local: No
Published: Mar 03 2013 12:00AM
Updated: Nov 02 2017 03:05PM
Credit: Michael Riedel.
Vulnerable: Apache Wicket 6.3
Apache Wicket 6.2
Apache Wicket 6.1
Apache Wicket 1.5.9
Apache Wicket 1.4.15
Apache Wicket 1.4.10
Apache Wicket 1.4.9
Apache Wicket 6.0
Apache Wicket 1.5.8
Apache Wicket 1.5.7
Apache Wicket 1.5.6
Apache Wicket 1.5.5
Apache Wicket 1.5.4
Apache Wicket 1.5.2
Apache Wicket 1.5.1
Apache Wicket 1.5.0
Apache Wicket 1.4.8
Apache Wicket 1.4.6
Apache Wicket 1.4.5
Apache Wicket 1.4.4
Apache Wicket 1.4.3
Apache Wicket 1.4.21
Apache Wicket 1.4.20
Apache Wicket 1.4.19
Apache Wicket 1.4.18
Apache Wicket 1.4.17
Apache Wicket 1.4.16
Apache Wicket 1.4.14
Apache Wicket 1.4.13
Apache Wicket 1.4.12
Apache Wicket 1.4.11
Apache Wicket 1.4.1


Not Vulnerable: Apache Wicket 6.4
Apache Wicket 1.5.10
Apache Wicket 1.4.22


Exploit


Attackers can exploit this issue by enticing an unsuspecting user to follow a malicious URI.


References:

Related Posts

Comments