PHP CVE-2017-16642 Heap Based Buffer Overflow Vulnerability



PHP is prone to a heap-based buffer-overflow vulnerability.

Attackers can exploit this issue to execute arbitrary code with elevated privileges within the context of a privileged process.

PHP versions prior to 5.6.32, 7.x prior to 7.0.25, and 7.1.x prior to 7.1.11 are vulnerable.

Information

Bugtraq ID: 101745
Class: Failure to Handle Exceptional Conditions
CVE: CVE-2017-16642

Remote: Yes
Local: No
Published: Nov 07 2017 12:00AM
Updated: Nov 07 2017 12:00AM
Credit: The vendor reported this issue.
Vulnerable: PHP PHP 7.1.8
PHP PHP 7.1.7
PHP PHP 7.1.6
PHP PHP 7.1.5
PHP PHP 7.1.4
PHP PHP 7.1.1
PHP PHP 7.1
PHP PHP 7.0.22
PHP PHP 7.0.21
PHP PHP 7.0.17
PHP PHP 7.0.16
PHP PHP 7.0.15
PHP PHP 7.0.14
PHP PHP 7.0.12
PHP PHP 7.0.5
PHP PHP 5.6.31
PHP PHP 5.6.30
PHP PHP 5.6.29
PHP PHP 5.6.27
PHP PHP 5.6.22
PHP PHP 5.6.21
PHP PHP 5.6.20
PHP PHP 5.6.19
PHP PHP 5.6.18
PHP PHP 5.6.17
PHP PHP 5.6.13
PHP PHP 5.6.12
PHP PHP 5.6.11
PHP PHP 5.6.5
PHP PHP 5.6.4
PHP PHP 5.6.1
PHP PHP 5.6
PHP PHP 5.5.38
PHP PHP 5.5.35
PHP PHP 5.5.34
PHP PHP 5.5.33
PHP PHP 5.5.32
PHP PHP 5.5.29
PHP PHP 5.5.28
PHP PHP 5.5.27
PHP PHP 5.5.26
PHP PHP 5.5.21
PHP PHP 5.5.14
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ S.u.S.E. Linux Personal 9.2
+ Turbolinux Turbolinux Server 10.0
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
PHP PHP 5.5.13
PHP PHP 5.5.12
PHP PHP 5.5.11
PHP PHP 5.5.10
PHP PHP 5.5.6
PHP PHP 5.5.5
PHP PHP 5.5.4
PHP PHP 5.5.3
PHP PHP 5.5.1
PHP PHP 5.4.45
PHP PHP 5.4.44
PHP PHP 5.4.43
PHP PHP 5.4.37
PHP PHP 5.4.30
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ S.u.S.E. Linux Personal 9.2
+ Turbolinux Turbolinux Server 10.0
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
PHP PHP 5.4.29
PHP PHP 5.4.26
PHP PHP 5.4.25
PHP PHP 5.4.8
PHP PHP 5.4.7
PHP PHP 5.4.6
PHP PHP 5.4.4
PHP PHP 5.4.3
PHP PHP 5.4.2
PHP PHP 5.4.1
PHP PHP 5.3.29
PHP PHP 5.3.28
PHP PHP 5.3.24
PHP PHP 5.3.23
PHP PHP 5.3.22
PHP PHP 5.3.21
PHP PHP 5.3.20
PHP PHP 5.3.17
PHP PHP 5.3.16
PHP PHP 5.3.14
PHP PHP 5.3.13
PHP PHP 5.3.12
PHP PHP 5.3.9
PHP PHP 5.3.8
PHP PHP 5.3.7
PHP PHP 5.3.6
PHP PHP 5.3.5
PHP PHP 5.3.2
PHP PHP 5.3.1
PHP PHP 5.3
PHP PHP 5.2.17
PHP PHP 5.2.16
PHP PHP 5.2.15
PHP PHP 5.2.13
PHP PHP 5.2.12
PHP PHP 5.2.11
PHP PHP 5.2.10
PHP PHP 5.2.9
PHP PHP 5.2.8
PHP PHP 5.2.7
PHP PHP 5.2.6
PHP PHP 5.2.5
PHP PHP 5.2.4
PHP PHP 5.2.3
PHP PHP 5.2.2
PHP PHP 5.2.1
+ Ubuntu Ubuntu Linux 7.04 sparc
+ Ubuntu Ubuntu Linux 7.04 powerpc
+ Ubuntu Ubuntu Linux 7.04 i386
+ Ubuntu Ubuntu Linux 7.04 amd64
PHP PHP 5.1.6
PHP PHP 5.1.5
PHP PHP 5.1.4
PHP PHP 5.1.3
PHP PHP 5.1.2
PHP PHP 5.1.1
PHP PHP 5.1
PHP PHP 5.0.5
PHP PHP 5.0.4
PHP PHP 5.0.3
PHP PHP 5.0.2
PHP PHP 5.0.1
PHP PHP 7.1.3
PHP PHP 7.0.9
PHP PHP 7.0.8
PHP PHP 7.0.7
PHP PHP 7.0.6
PHP PHP 7.0.4
PHP PHP 7.0.2
PHP PHP 7.0.13
PHP PHP 7.0.11
PHP PHP 7.0.10
PHP PHP 7.0.1
PHP PHP 7.0
PHP PHP 5.6.9
PHP PHP 5.6.8
PHP PHP 5.6.7
PHP PHP 5.6.6
PHP PHP 5.6.3
PHP PHP 5.6.28
PHP PHP 5.6.26
PHP PHP 5.6.25
PHP PHP 5.6.24
PHP PHP 5.6.23
PHP PHP 5.6.2
PHP PHP 5.6.14
PHP PHP 5.6.10
PHP PHP 5.5.9
PHP PHP 5.5.8
PHP PHP 5.5.7
PHP PHP 5.5.37
PHP PHP 5.5.36
PHP PHP 5.5.31
PHP PHP 5.5.30
PHP PHP 5.5.25
PHP PHP 5.5.24
PHP PHP 5.5.23
PHP PHP 5.5.22
PHP PHP 5.5.20
PHP PHP 5.5.2
PHP PHP 5.5.19
PHP PHP 5.5.18
PHP PHP 5.5.17
PHP PHP 5.5.16
PHP PHP 5.5.15
PHP PHP 5.4.9
PHP PHP 5.4.5
PHP PHP 5.4.42
PHP PHP 5.4.41
PHP PHP 5.4.40
PHP PHP 5.4.39
PHP PHP 5.4.38
PHP PHP 5.4.36
PHP PHP 5.4.35
PHP PHP 5.4.34
PHP PHP 5.4.33
PHP PHP 5.4.32
PHP PHP 5.4.31
PHP PHP 5.4.28
PHP PHP 5.4.27
PHP PHP 5.4.24
PHP PHP 5.4.23
PHP PHP 5.4.22
PHP PHP 5.4.21
PHP PHP 5.4.20
PHP PHP 5.4.12
PHP PHP 5.4.11
PHP PHP 5.4.10
PHP PHP 5.3.4
PHP PHP 5.3.3
PHP PHP 5.3.27
PHP PHP 5.3.26
PHP PHP 5.3.25
PHP PHP 5.3.19
PHP PHP 5.3.18
PHP PHP 5.3.15
PHP PHP 5.3.11
PHP PHP 5.3.10
PHP PHP 5.2.14
PHP PHP 5.1.43
+ Ubuntu Ubuntu Linux 6.10 sparc
+ Ubuntu Ubuntu Linux 6.10 powerpc
+ Ubuntu Ubuntu Linux 6.10 i386
+ Ubuntu Ubuntu Linux 6.10 amd64


Not Vulnerable: PHP PHP 7.1.11
PHP PHP 7.0.25
PHP PHP 5.6.32


Exploit


The researcher has created a proof-of-concept to demonstrate the issue. Please see the references for more information.


References:

Related Posts

Comments