Redis CVE-2016-10517 Cross Site Scripting Vulnerability

Redis is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied text.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

Redis versions prior to 3.2.7 are vulnerable.


Bugtraq ID: 101572
Class: Input Validation Error
CVE: CVE-2016-10517

Remote: Yes
Local: No
Published: Oct 24 2017 12:00AM
Updated: Oct 24 2017 12:00AM
Credit: The vendor reported the issue.
Vulnerable: Redis Redis 3.2.3
Redis Redis 3.0.2
Redis Redis 2.8.21

Not Vulnerable: Redis Redis 3.2.7


An attacker can exploit this issue by enticing an unsuspecting user to follow a malicious URI.

Related Posts