Node.js ejs Package 'ejs.renderFile()' function Cross Site Scripting Vulnerability

The ejs Package for Node.js is prone to a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch code injection attacks.

Versions prior to ejs 2.5.5 are vulnerable.


Bugtraq ID: 101889
Class: Input Validation Error
CVE: CVE-2017-1000188

Remote: Yes
Local: No
Published: Nov 16 2017 12:00AM
Updated: Nov 20 2017 02:08PM
Credit: Snyk Security Research Team.
Vulnerable: mde ejs 2.5.4
mde ejs 2.5.3
mde ejs 2.5.2
mde ejs 2.5.1
mde ejs 2.4.2
mde ejs 2.4.1
mde ejs 2.3.4

Not Vulnerable: mde ejs 2.5.5


To exploit this issue, an attacker must entice an unsuspecting victim to follow a malicious URI.

Related Posts