Wireshark 'epan/dissectors/packet-cipsafety.c' Denial of Service Vulnerability



Wireshark is prone to a remote denial-of-service vulnerability because it fails to properly handle certain types of packets.

An attacker can leverage this issue to crash the affected application, denying service to legitimate users.
Wireshark versions 2.4.0 through 2.4.2, and 2.2.0 through 2.2.10 are vulnerable.

Information

Bugtraq ID: 102071
Class: Failure to Handle Exceptional Conditions
CVE: CVE-2017-17085

Remote: Yes
Local: No
Published: Nov 30 2017 12:00AM
Updated: Dec 06 2017 09:11PM
Credit: The vendor reported this issue.
Vulnerable: Wireshark Wireshark 2.4.1
Wireshark Wireshark 2.4
Wireshark Wireshark 2.2.10
Wireshark Wireshark 2.2.9
Wireshark Wireshark 2.2.8
Wireshark Wireshark 2.2.7
Wireshark Wireshark 2.2.6
Wireshark Wireshark 2.2.5
Wireshark Wireshark 2.2.4
Wireshark Wireshark 2.2.3
Wireshark Wireshark 2.2.2
Wireshark Wireshark 2.2.1
Wireshark Wireshark 2.2
Wireshark Wireshark 2.4.2


Not Vulnerable: Wireshark Wireshark 2.4.3
Wireshark Wireshark 2.2.11


Exploit


A sample packet trace file is available in the Wireshark bug report. Please see the references for more information.


Related Posts

Comments