WordPress Pinterest Badge 1.8.0 Cross Site Scripting

WordPress Pinterest Badge plugin version 1.8.0 suffers from a cross site scripting vulnerability.


MD5 | be0616ede646b5b6c06ff210352d9033

Class Input Validation Error
Remote Yes

Credit Ricardo Sanchez
Vulnerable Pinterest Badge 1.8.0

Pinterest Badge is prone to a stored cross-site scripting
vulnerability because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage this issue to execute arbitrary script code in the
browser of an unsuspecting user in the context of the affected site. This
may allow the attacker to steal cookie-based authentication credentials and
to launch other attacks.

To exploit this issue following steps:
The XSS reflected because the value uid is not filter correctly:


Demo Request:
http://localhost//wordpress/wp-content/plugins/pinterest-
badge/pinterestbadgedetails.php?uid=</script>"><script>alert("R1XS4.COM
")</script>

Related Posts