WordPress WP Mailster 1.5.4.0 Cross Site Scripting

WordPress WP Mailster plugin version 1.5.4.0 suffers from a persistent cross site scripting vulnerability.


MD5 | b99fe238c6deceb9c0356cc5201dd253

Class Input Validation Error
Remote Yes

Credit Ricardo Sanchez
Vulnerable WP Mailster 1.5.4.0

WP Mailster is prone to a stored cross-site scripting
vulnerability because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage this issue to execute arbitrary script code in the
browser of an unsuspecting user in the context of the affected site. This
may allow the attacker to steal cookie-based authentication credentials and
to launch other attacks.

To exploit this issue following steps:
The XSS reflected because the value mes is not filter correctly:


Demo Request:
http://localhost//wordpress/wp-content/plugins/wp-mailster/view/subscription/unsubscribe2.php?mes=
</script>"><script>alert("XSS")</script>

Related Posts