MyBB Thank You / Like 3.0.0 Cross Site Scripting

MyBB Thank You and Like plugins version 3.0.0 suffer from a cross site scripting vulnerability.


MD5 | c3a55008b7489410249bcbecd27f45f4

# Exploit Title: MyBB Thank You/Like Plugin 3.0.0 - Cross-Site Scripting
# Date: 8/1/2018
# Author: 0xB9
# Twitter: @0xB9Sec
# Contact: 0xB9[at]pm.me
# Software Link: https://community.mybb.com/mods.php?action=view&pid=360
# Version: 3.0.0
# Tested on: Ubuntu 18.04
# CVE: CVE-2018-14888


1. Description:
This plugin allows users to thank/like other users threads/posts. In user profiles it shows your most liked post/thread, the post/thread subjects aren't sanitized to user input.


2. Proof of Concept:

- Use the following as the post/thread subject <script>alert('XSS')</script>
- Get that post/thread liked by another user (or you)
- Visit your profile to see alert.


3. Solution:
Update to v3.1.0


Related Posts