WordPress Prior to 4.8.2 Multiple Input Validation Security Vulnerabilities



WordPress is prone to the following input-validation security vulnerabilities because it fails to sufficiently sanitize user-supplied input:

1. Multiple cross-site scripting vulnerabilities
2. Multiple directory-traversal vulnerabilities
3. An open-redirection vulnerability
4. An SQL-injection vulnerability

An attacker can exploit these issues to steal cookie-based authentication credentials, to redirect a user to an attacker-controlled site; this may aid in phishing attacks , to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.; and to read arbitrary files in the context of the application.

WordPress versions 4.8.1 and earlier are affected.

Information

Bugtraq ID: 100912
Class: Unknown
CVE:
Remote: Yes
Local: No
Published: Sep 19 2017 12:00AM
Updated: Sep 19 2017 12:00AM
Credit: Slavco,xknown,Rodolfo Assis (@brutelogic) of Sucuri Security, Alex Chapman,Chen Ruiq, Yasin Soliman, Weston Ruter of the WordPress Security Team, Luka,Anas Roubi.
Vulnerable: WordPress WordPress 4.8.1
WordPress WordPress 4.7.4
WordPress WordPress 4.7.2
WordPress WordPress 4.7.1
WordPress WordPress 4.6.1
WordPress WordPress 4.5.2
WordPress WordPress 4.5.1
WordPress WordPress 4.5
WordPress WordPress 4.4.1
WordPress WordPress 4.4
WordPress WordPress 4.2.4
WordPress WordPress 4.2.3
WordPress WordPress 4.2.2
WordPress WordPress 4.2.1
WordPress WordPress 4.1.2
WordPress WordPress 4.1.1
WordPress WordPress 4.1
WordPress WordPress 3.9.2
WordPress WordPress 3.9.1
WordPress WordPress 3.9
WordPress WordPress 3.8.2
WordPress WordPress 3.8.1
WordPress WordPress 3.7.4
WordPress WordPress 3.7.1
WordPress WordPress 3.6.1
WordPress WordPress 3.6
WordPress WordPress 3.5.2
WordPress WordPress 3.5.1
WordPress WordPress 3.3.2
WordPress WordPress 3.2.2
WordPress WordPress 3.1.4
WordPress WordPress 3.1.3
WordPress WordPress 3.1.2
WordPress WordPress 3.1.1
WordPress WordPress 3.0.5
WordPress WordPress 3.0.4
WordPress WordPress 3.0.3
WordPress WordPress 3.0.2
WordPress WordPress 2.9.2
WordPress WordPress 2.9.1
WordPress WordPress 2.8.6
WordPress WordPress 2.8.5
WordPress WordPress 2.8.4
WordPress WordPress 2.8.3
WordPress WordPress 2.8.2
WordPress WordPress 2.8.1
WordPress WordPress 2.3.3
WordPress WordPress 2.3.2
WordPress WordPress 2.3.1
WordPress WordPress 2.2.3
WordPress WordPress 2.2.2
WordPress WordPress 2.2.1
WordPress WordPress 2.0.11
WordPress WordPress 2.0.7
WordPress WordPress 2.0.6
WordPress WordPress 2.0.5
WordPress WordPress 2.0.4
WordPress WordPress 2.0.3
WordPress WordPress 2.0.2
WordPress WordPress 1.3.1
WordPress WordPress 1.2.2
WordPress WordPress 1.2.1
WordPress WordPress 1.2
WordPress WordPress 4.7.5
WordPress WordPress 4.7.3
WordPress WordPress 4.7
WordPress WordPress 4.6
WordPress WordPress 4.5.3
WordPress WordPress 4.4.2
WordPress WordPress 4.3.1
WordPress WordPress 4.3
WordPress WordPress 4.2
WordPress WordPress 4.0.1
WordPress WordPress 4.0
WordPress WordPress 3.9.3
WordPress WordPress 3.9
WordPress WordPress 3.8.5
WordPress WordPress 3.8.4
WordPress WordPress 3.8.3
WordPress WordPress 3.8
WordPress WordPress 3.7.5
WordPress WordPress 3.7
WordPress WordPress 3.5.0
WordPress WordPress 3.5
WordPress WordPress 3.4.2
WordPress WordPress 3.4.1
WordPress WordPress 3.4
WordPress WordPress 3.3.3
WordPress WordPress 3.3.1
WordPress WordPress 3.3
WordPress WordPress 3.2.1
WordPress WordPress 3.1
WordPress WordPress 3.0.6
WordPress WordPress 3.0.1
WordPress WordPress 2.9.1.1
WordPress WordPress 2.9
WordPress WordPress 2.8.5.2
WordPress WordPress 2.8.5.1
WordPress WordPress 2.8
WordPress WordPress 2.3
WordPress WordPress 2.1
WordPress WordPress 1.3.3
WordPress WordPress 1.2.5
WordPress WordPress 1.2.3
WordPress WordPress 0.6.2.1


Not Vulnerable: WordPress WordPress 4.8.2


Exploit


Attackers can exploit this issue by enticing an unsuspecting victim to follow a malicious URI, or using a browser or readily available tools.


Related Posts

Comments