Bugzilla 4.4.12 / 5.0.3 Cross Site Request Forgery

Bugzilla versions 2.16rc1 to 4.4.12 and 4.5.1 to 5.0.3 suffer from a cross site request forgery vulnerability.

MD5 | 63fc7fa848089d24714108e1c4258528


Bugzilla is a Web-based bug-tracking system used by a large number of
software projects. The following security issue has been discovered
in Bugzilla:

* A CSRF vulnerability in report.cgi would allow a third-party site
to extract confidential information from a bug the victim had access to.

All affected installations are encouraged to upgrade as soon as

Vulnerability Details

Class: Cross-Site Request Forgery
Versions: Bugzilla 2.16rc1 to 4.4.12, 4.5.1 to 5.0.3
Fixed In: 4.4.13, 5.0.4
Description: Via the image generation in report.cgi, a malicious site
using the presence of certain images, could extract
potentially confidential information if the victim was
logged in and could access the bug.
References: https://bugzilla.mozilla.org/show_bug.cgi?id=1433400
CVE Number: CVE-2018-5123

Vulnerability Solutions

The fix for this issue is included in the 4.4.13 and 5.0.4
releases. Upgrading to a release with the relevant fix will
protect your installation from possible exploits of this issue.

If you are unable to upgrade but would like to patch just the security
vulnerability, there are patches available for the issue at the
"References" URL.

Full release downloads, patches to upgrade Bugzilla from previous
versions, and git upgrade instructions are available at:



The Bugzilla team wish to thank the following people for their
assistance in locating, advising us of, and assisting us to fix this

Reporter: Holger Fuhrmannek
Fixed by: Dylan Hardison

General information about the Bugzilla bug-tracking system can be found


Comments and follow-ups can be directed to the mozilla.support.bugzilla
newsgroup or the support-bugzilla mailing list.
https://www.bugzilla.org/support/ has directions for accessing these

Related Posts