MyBB My Arcade 1.3 Cross Site Scripting

MyBB My Arcade plugin version 1.3 suffers from a cross site scripting vulnerability.

MD5 | db17a1a287de15c1f89c6789e1cf6e44

# Exploit Title: MyBB My Arcade Plugin v1.3 - Persistent XSS
# Date: 2/21/2018
# Author: 0xB9
# Contact: or 0xB9[at]
# Software Link:
# Version: 1.3
# Tested on: Ubuntu 17.10

1. Description:
The My Arcade plugin adds a page of arcade games and keeps track of user scores, also allowing users to add a comment next to their score. The comment box is vulnerable to a persistent XSS.

2. Proof of Concept:

Persistent XSS
- Play an arcade game
- Add the following comment to your score <p """><SCRIPT>alert("XSS")</SCRIPT>">
- Edit the comment, Boom.

3. Solution:
Update to 1.3.1

Related Posts