Squid CVE-2019-13345 Multiple Cross Site Scripting Vulnerabilities

Squid is prone to multiple cross-site scripting vulnerabilities because it fails to sanitize user-supplied input.

An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and launch other attacks.

Squid versions through 4.7 are vulnerable.


Bugtraq ID: 109095
Class: Input Validation Error
CVE: CVE-2019-13345

Remote: Yes
Local: No
Published: May 27 2019 12:00AM
Updated: May 27 2019 12:00AM
Credit: PAZ
Vulnerable: Squid Squid 4.0.17
Squid Squid 4.0.16
Squid Squid 4.0.8
Squid Squid 4.0.6
Squid Squid 4.0.5
Squid Squid 4.0.4
Squid Squid 4.7
Squid Squid 4.6
Squid Squid 4.5
Squid Squid 4.4
Squid Squid 4.0.9
Squid Squid 4.0.7
Squid Squid 4.0.10
Squid Squid 4.0

Not Vulnerable: Squid Squid 4.8


An attacker can exploit these issues by enticing an unsuspecting user to visit a specially crafted URL.

Related Posts