pfsense 2.3.2 Cross Site Request Forgery

pfsense versions 2.3.2 suffers from a cross site request forgery vulnerability.

MD5 | e0aebdcf832a3eedba8cce38da046e50

Security Advisory - Curesec Research Team

1. Introduction

Affected Product: pfsense 2.3.2
Fixed in: 2.3.3
Fixed Version Link:
Vendor Website:
Vulnerability Type: CSRF
Remote Exploitable: Yes
Reported to vendor: 02/06/2017
Disclosed to public: 03/24/2017
Release mode: Coordinated Release
CVE: requested via DWF
Credits Tim Coen of Curesec GmbH

2. Overview

pfsense is an open source firewall. The web interface is written in PHP. In
version 2.3.2-RELEASE (amd64), the actions of creating and deleting firewall
rules are vulnerable to CSRF, enabling an Attacker to edit these rules with a
little bit of social engineering.

3. Details

CVSS: Medium; 5.4

Description: The easyrule.php script is vulnerable to CSRF, which allows an
attacker to create or delete firewall rules via CSRF.

Proof of Concept:

GET /easyrule.php?action=pass&int=LAN&proto=any&src=

4. Solution

To mitigate this issue please upgrade at least to version 2.3.3:

Please note that a newer version might already be available.

5. Report Timeline

02/06/2017 Informed Vendor about Issue
02/07/2017 Vendor confirms + fixes issues in git
02/20/2017 Vendor relases fix + vendor advisory
03/24/2017 Disclosed to public

Blog Reference:

Atom Feed:
RSS Feed:

Curesec GmbH
Curesec Research Team
Josef-Orlopp-StraAe 54
10365 Berlin, Germany

Related Posts